SETI@home v7 6.98 for ATI OpenCL released.

log in

Advanced search

Message boards : News : SETI@home v7 6.98 for ATI OpenCL released.

Previous · 1 . . . 4 · 5 · 6 · 7
Author Message
Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar
Send message
Joined: 15 Mar 05
Posts: 1333
Credit: 15,162,669
RAC: 16,855
Message 44518 - Posted: 13 Dec 2012, 22:02:07 UTC - in response to Message 44513.

I'm also having AMD driver woes on Angela's machine an update to the highest recommended driver for the card (12.8) causes the machine to reboot whenever BOINC probes the card. It appears that any OpenCL API calls cause the reboot.

A downgrade back to the original driver didn't solve the problem, so there must be some component that doesn't properly downgrade.

This sort of thing is why the AMD graphics card is on my wife's machine. In the last 10 years I've owned three AMD/ATI cards, and this sort of problem when updating drivers has been the rule rather than the exception.
____________

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44519 - Posted: 13 Dec 2012, 22:31:40 UTC - in response to Message 44518.
Last modified: 13 Dec 2012, 22:49:08 UTC

OpenCL support for Windows XP is deprecated from Cat 12.2, the last driver that can be installed where CAL and OpenCL work is Cat 12.1

http://www.hal6000.com/seti/boinc_ati_gpu_cheat_sheet.htm

Claggy

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44520 - Posted: 13 Dec 2012, 22:39:18 UTC - in response to Message 44518.

I'm in the process of downgrading from Cat 12.11 Beta to Cat 12.8,
The AMD uninstaller leaves amdocl64.dll behind in the System32 directory, and amdocl.dll in the SysWOW64 directory,

Claggy

Profile Eric J Korpela
Volunteer moderator
Project administrator
Project developer
Project scientist
Avatar
Send message
Joined: 15 Mar 05
Posts: 1333
Credit: 15,162,669
RAC: 16,855
Message 44522 - Posted: 13 Dec 2012, 23:29:28 UTC - in response to Message 44519.

OpenCL support for Windows XP is deprecated from Cat 12.2, the last driver that can be installed where CAL and OpenCL work is Cat 12.1

http://www.hal6000.com/seti/boinc_ati_gpu_cheat_sheet.htm



Yeah, it would be nice if AMD's tool that selects the best driver version for your combination of OS and GPU knew about that. That's where I got the hairbrained idea to go for 12.8.

I think it's gotten to the point where I won't even buy their GPUs to test them with BOINC.

____________

Profile Mike
Volunteer tester
Avatar
Send message
Joined: 16 Jun 05
Posts: 2076
Credit: 733,693
RAC: 4,315
Message 44529 - Posted: 14 Dec 2012, 14:39:25 UTC

If i`m not mistaken, i told you that already Eric.

____________

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44550 - Posted: 14 Dec 2012, 19:24:46 UTC - in response to Message 44505.
Last modified: 14 Dec 2012, 19:25:14 UTC

It's hard to remove AMD drivers completely.
Here what AMD support recommends to to to cleanup current driver version more or less totally:


1. Download the WICU.
http://www.softpedia.com/get/Security/Secure-cleaning/Windows-Installer-CleanUp-Utility.shtml

2. Uninstall everything related to ATI/AMD and reboot through programs and
features in the Control Panel (programs and features).
Use Driver Fusion (freeware) to remove any remnants of AMD (check the "AMD
Display" box) (http://treexy.com/products/driver-fusion).

3. Launch WICU and delete anything related to ATI/AMD/CCC.

4. Delete all ATI/AMD folders in "C:\Program Files" and "C:\Program Files
(x86)".

5. Boot into safemode and navigate to the "C:\Windows\Assembly" folder and
delete any assemblies which have the public token key "90ba9c70f846762e". It
is possible that you won't find any, but check it.

6. Reboot.

7. Install the Catalyst package again.


I've managed to partially break my i7-2600K's Win 7 Installation following the above,
I've got no Audio Service, Aero is off, some of the hardware detection doesn't work, so CPU-Z gives very minimal information, Hardware Monitor only gives one temperature, GPU-Z won't run (says it can't run in safe mode)
while i managed to install the Nvidia 310.70 drivers, the update service wouldn't install, and the Catalyst Installer can't install because it failed to load detection driver,
I've rebooted a few times, as far as i can tell i'm not in Safe Mode, looks as i'll have to try a Win 7 repair installation.

Claggy

Richard Haselgrove
Volunteer tester
Send message
Joined: 3 Jan 07
Posts: 1117
Credit: 2,898,641
RAC: 1,288
Message 44552 - Posted: 14 Dec 2012, 19:44:03 UTC - in response to Message 44550.

I've managed to partially break my i7-2600K's Win 7 Installation following the above,
I've got no Audio Service, Aero is off, some of the hardware detection doesn't work, so CPU-Z gives very minimal information, Hardware Monitor only gives one temperature, GPU-Z won't run (says it can't run in safe mode)
while i managed to install the Nvidia 310.70 drivers, the update service wouldn't install, and the Catalyst Installer can't install because it failed to load detection driver,
I've rebooted a few times, as far as i can tell i'm not in Safe Mode, looks as i'll have to try a Win 7 repair installation.

Claggy

I'd try a System Restore before you go to the full repair install.

Do you still have network drivers? Networking has also gone, when I've encountered s****-ups like that: but system restore from the repair console - plus a lot of patience, even when it seems not to be making progress - has solved it each time so far.

Of course, if you do restore successfully, you get the drivers back, and then you have to start over again...

Profile Raistmer
Volunteer tester
Avatar
Send message
Joined: 18 Aug 05
Posts: 1630
Credit: 10,079,795
RAC: 997
Message 44564 - Posted: 15 Dec 2012, 14:25:51 UTC - in response to Message 44550.
Last modified: 15 Dec 2012, 14:30:46 UTC

I've managed to partially break my i7-2600K's Win 7 Installation following the above,

Claggy


Sad to hear that, but that sequence just copy-paste from E-mail I recived as troubleshoting of BSoDs on my HD6950 host...
I'm afraid level of support from AMD constantly degrades... Same on their forums - some new person on OpenCL forum that can only ask for test cases it seems...

[ADDON: on my own host it doesn't kill Vista installation, I was able to do clean install of Cat 12.11 beta8... but this fact changed nothing, BSoDs continued, AMD support had no idea besides to claim that HD6950 too fast for my PCI-E V1 motherboard... (it worked Ok with older drivers more than year, BTW, so such claim looks quite ridiculous. After this I stopped responding on troubleshooting letters).]

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44630 - Posted: 19 Dec 2012, 14:28:09 UTC - in response to Message 44552.

I've managed to partially break my i7-2600K's Win 7 Installation following the above,
I've got no Audio Service, Aero is off, some of the hardware detection doesn't work, so CPU-Z gives very minimal information, Hardware Monitor only gives one temperature, GPU-Z won't run (says it can't run in safe mode)
while i managed to install the Nvidia 310.70 drivers, the update service wouldn't install, and the Catalyst Installer can't install because it failed to load detection driver,
I've rebooted a few times, as far as i can tell i'm not in Safe Mode, looks as i'll have to try a Win 7 repair installation.

Claggy

I'd try a System Restore before you go to the full repair install.

Do you still have network drivers? Networking has also gone, when I've encountered s****-ups like that: but system restore from the repair console - plus a lot of patience, even when it seems not to be making progress - has solved it each time so far.

Of course, if you do restore successfully, you get the drivers back, and then you have to start over again...

I've finally managed to try that, and it worked, just installed the lastest 310.70 WHQL Nvidia drivers, a new System restore point is next, then i'll manually remove the AMD Cat 12.11 drivers/APP runtime, and cross my fingers,

Claggy

dancer42
Volunteer tester
Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,558
RAC: 0
Message 44737 - Posted: 24 Dec 2012, 10:03:18 UTC - in response to Message 44470.

yes and i found them i program data

I am sorry I am not as good as you claggy

I wouldn't trouble this board again for a long while.

Please stay, just post in a bit more detail what happens,

Claggy

====================================================
claggy I am back and I apologize for getting huffy.

I had a lot going on and was frustrated over not being able to find

files I had found and fixed before, it was stupid to not look

in program data goes without saying, every one has an is it plugged in day

once in a while.

I will try the surgical driver removal and downgrade.

then I will see if I can find out how to probe the cards

with opencl without crashing the driver.

wish me luck.
____________

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44738 - Posted: 24 Dec 2012, 10:44:27 UTC - in response to Message 44737.

Good Luck,

I managed go restore my i7-2600K/GTX460/HD7770 back to working order,
Didn't have time to remove the old AMD/ATI files, so just installed Cat 12.11 again,
will downgrade to Cat 12.8 after Christmas,

Claggy

B-Man
Volunteer tester
Send message
Joined: 24 Aug 09
Posts: 79
Credit: 26,117
RAC: 0
Message 44776 - Posted: 3 Jan 2013, 17:59:57 UTC

Any ETA on GPU support for OSX? I have a machine waiting .........

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44778 - Posted: 3 Jan 2013, 21:28:05 UTC - in response to Message 44776.

Any ETA on GPU support for OSX? I have a machine waiting .........

Basically No, Urs has been sorting out the Linux ATI port, and is now trying to get Stock v7 builds to produce strongly similar results, so OS X ATI support could be in a months time, or in a years time,
and i've yet to find out what the one member with the title 'porting team' does, his last post was a year and a half ago, and his only showing at Lunatics seems to be via a bot,
so as i far as i know Linux Cuda v7 support is at a standstill, and OS X Cuda development is non-existent, but everything is subject to change, it could be different next week.

Claggy

Claggy
Volunteer tester
Send message
Joined: 29 May 06
Posts: 906
Credit: 7,526,737
RAC: 1,463
Message 44873 - Posted: 24 Jan 2013, 21:47:23 UTC - in response to Message 44776.
Last modified: 24 Jan 2013, 21:47:48 UTC

Any ETA on GPU support for OSX? I have a machine waiting .........

a Mac user walked off the street and has promptly ported the x41zc Cuda app to the Mac, now awaiting a tester.

Claggy

zombie67 [MM]
Volunteer tester
Avatar
Send message
Joined: 18 May 06
Posts: 270
Credit: 18,456,231
RAC: 11,432
Message 44930 - Posted: 4 Feb 2013, 3:10:50 UTC - in response to Message 44873.

Any ETA on GPU support for OSX? I have a machine waiting .........

a Mac user walked off the street and has promptly ported the x41zc Cuda app to the Mac, now awaiting a tester.

Claggy


I am not sure what this means exactly, but I am willing to test. I have macs with both AMD and nVidia GPUs.
____________
Dublin, California
Team: SETI.USA

arkayn
Volunteer tester
Avatar
Send message
Joined: 16 Jan 07
Posts: 150
Credit: 194,400
RAC: 0
Message 44931 - Posted: 4 Feb 2013, 5:30:55 UTC - in response to Message 44930.

Any ETA on GPU support for OSX? I have a machine waiting .........

a Mac user walked off the street and has promptly ported the x41zc Cuda app to the Mac, now awaiting a tester.

Claggy


I am not sure what this means exactly, but I am willing to test. I have macs with both AMD and nVidia GPUs.


And you have been added to the testing pool.

Previous · 1 . . . 4 · 5 · 6 · 7

Message boards : News : SETI@home v7 6.98 for ATI OpenCL released.


Main page · Your account · Message boards


Copyright © 2014 University of California
AstroPulse is funded in part by the NSF through grant AST-0307956