Rescheduler Problem

Message boards : Number crunching : Rescheduler Problem
Message board moderation

To post messages, you must log in.

AuthorMessage
Terror Australis
Volunteer tester

Send message
Joined: 14 Feb 04
Posts: 1806
Credit: 247,505,763
RAC: 67,631
Australia
Message 1890721 - Posted: 19 Sep 2017, 4:18:28 UTC
Last modified: 19 Sep 2017, 4:19:29 UTC

For some reason, when I run Mr Kevvy's rescheduler. it quite happily moves all the "normal" units from CPU to GPU, but it has stopped moving the VLAR units back the other way (GPU -> CPU).
It has only just started doing this. As far as I can tell, nothing on the machine has changed, I've tried all the usual things (reboots, refreshing the resched's exe file, etc, but nothing has worked and it has me stumped...

Machine is QX9550, Win XP, 2 x GTX750 Ti's, starting the Resched with the -b option (and I'm inactive on Beta anyway)

All suggestions are welcome :)

T.A.
ID: 1890721 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 4478
Credit: 278,834,216
RAC: 630,701
United States
Message 1890802 - Posted: 20 Sep 2017, 0:07:28 UTC

Might it be a problem with the naming change caused by the 4 bit tasks?
Seti@Home classic workunits:20,676 CPU time:74,226 hours
ID: 1890802 · Report as offensive
Terror Australis
Volunteer tester

Send message
Joined: 14 Feb 04
Posts: 1806
Credit: 247,505,763
RAC: 67,631
Australia
Message 1890863 - Posted: 20 Sep 2017, 5:48:44 UTC - in response to Message 1890802.  

I don't think so. The Rescheduler is working ok on my other machine.
ID: 1890863 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 4478
Credit: 278,834,216
RAC: 630,701
United States
Message 1890868 - Posted: 20 Sep 2017, 6:09:44 UTC - in response to Message 1890863.  

Yes, I agree. Just used it on all Windows machines and had no issues. I had the usual 1 for 1 swap. Don't know what happened with your machine. Maybe the client_state was still open or maybe the machine just needs a reboot to clear the cobwebs.
Seti@Home classic workunits:20,676 CPU time:74,226 hours
ID: 1890868 · Report as offensive
Terror Australis
Volunteer tester

Send message
Joined: 14 Feb 04
Posts: 1806
Credit: 247,505,763
RAC: 67,631
Australia
Message 1890982 - Posted: 20 Sep 2017, 17:35:32 UTC

Well, It's working again. I went into "OpenCL Mode", NNT, paused Cuda50 work, and crunched out all the VLAR Units. Once they had been taken off the books ,it started working again.
I'm wondering, if an attempt has been made to resched a unit that failed due insufficient "normal" units on the CPU. Is it somehow marked as "untransferable" and from then on is ignored by the Rescheduler and is thus permanently left behind....
ID: 1890982 · Report as offensive
Profile Keith Myers Special Project $250 donor
Volunteer tester
Avatar

Send message
Joined: 29 Apr 01
Posts: 4478
Credit: 278,834,216
RAC: 630,701
United States
Message 1890998 - Posted: 20 Sep 2017, 18:36:06 UTC - in response to Message 1890982.  

I don't think that is the case but what do I know. Only Mr. Kevvy and Jimbocous can answer those questions I suspect. If there is a problem with moving candidates you usually just get the error message that no tasks were available for moving.
Seti@Home classic workunits:20,676 CPU time:74,226 hours
ID: 1890998 · Report as offensive

Message boards : Number crunching : Rescheduler Problem


 
©2018 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.