Ubuntu + AMD HD 8570: Is there a driver/config that works?

Message boards : Number crunching : Ubuntu + AMD HD 8570: Is there a driver/config that works?
Message board moderation

To post messages, you must log in.

AuthorMessage
hostmaster
Avatar

Send message
Joined: 23 Jul 00
Posts: 2
Credit: 3,158,162
RAC: 24,183
United States
Message 1902095 - Posted: 20 Nov 2017, 20:40:59 UTC

I've tried several variations of config and drivers to try to get the GPU working with Boinc on an older system. Tried both kernels 4.4 and 4.10, Ubuntu is on 16.04.3-LTS. Have tried both the opensource AMD driver and the AMDGPU-PRO driver (17.40). The driver does support this GPU https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx :

Should I chalk this down to immature AMD support and move on? I was going to retire this kit but thought I'd give boinc a whirl, just for giggles. At this point I'm kind of embarrassed by the amount of time I've spent trying to get this to work. I've seen other threads, notably this one, with people going through the same rigmarole and then giving up: https://boinc.berkeley.edu/dev/forum_thread.php?id=11630&postid=78341#78341

The computer in question is: https://setiathome.berkeley.edu/show_host_detail.php?hostid=8303993

The GPU is identified by the system correctly:

$ lspci|grep -i vga
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM]


Boinc sees it too (from boinc.log)

17-Nov-2017 17:12:46 [---] OpenCL: AMD/ATI GPU 0: AMD Radeon HD 8500 Series (driver version 2482.3, device version OpenCL 1.2 AMD
-APP (2482.3), 782MB, 782MB available, 599 GFLOPS peak)


But, tasks keep getting postponed when I enable GPU computation:
17-Nov-2017 17:13:20 [---] Resuming GPU computation
17-Nov-2017 17:13:21 [SETI@home] task postponed 30.000000 sec: 
17-Nov-2017 17:13:22 [SETI@home] task postponed 30.000000 sec: 


They will eventually time out, and fail after retries with the message "too many boinc_temporary_exit()s". . The task stderr looks like this:
/var/lib/boinc-client/slots/29$ more stderr.txt 
OpenCL platform detected: Advanced Micro Devices, Inc.
Number of OpenCL devices found : 1 
BOINC assigns slot on device #0.
Info: BOINC provided OpenCL device ID used
ERROR: OpenCL kernel/call 'Creating Command Queue. (clCreateCommandQueue)' call failed (-6) in file ../../src/GPU_lock.cpp near l
ine 1359.
Waiting 30 sec before restart...


Both opencl_ati5_nocal and opencl_ati5_SoG_nocal tasks fail in the same way.

An example of a task that has errored out is here: https://setiathome.berkeley.edu/result.php?resultid=6170921519

clinfo output:
Number of platforms                               1
  Platform Name                                   AMD Accelerated Parallel Processing
  Platform Vendor                                 Advanced Micro Devices, Inc.
  Platform Version                                OpenCL 2.0 AMD-APP (2482.3)
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_icd cl_amd_event_callback cl_amd_offline_devices 
  Platform Extensions function suffix             AMD

  Platform Name                                   AMD Accelerated Parallel Processing
Number of devices                                 1
  Device Name                                     Oland
  Device Vendor                                   Advanced Micro Devices, Inc.
  Device Vendor ID                                0x1002
  Device Version                                  OpenCL 1.2 AMD-APP (2482.3)
  Driver Version                                  2482.3
  Device OpenCL C Version                         OpenCL C 1.2 
  Device Type                                     GPU
  Device Profile                                  FULL_PROFILE
  Device Board Name (AMD)                         AMD Radeon HD 8500 Series
  Device Topology (AMD)                           PCI-E, 01:00.0
  Max compute units                               6
  SIMD per compute unit (AMD)                     4
  SIMD width (AMD)                                16
...
  Device Extensions                               cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_ex
tended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_int64_base_atomics cl_khr_int64_extende
d_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_sharing cl_amd_device_attribute_query cl_amd_vec3 cl_amd
_printf cl_amd_media_ops cl_amd_media_ops2 cl_amd_popcnt cl_khr_image2d_from_buffer cl_khr_spir cl_khr_gl_event 
ID: 1902095 · Report as offensive     Reply Quote
TBar
Volunteer tester

Send message
Joined: 22 May 99
Posts: 3895
Credit: 200,374,313
RAC: 211,724
United States
Message 1902136 - Posted: 21 Nov 2017, 2:47:25 UTC - in response to Message 1902095.  

I don't know about the Newer drivers, but, you should be able to get it working with the Older drivers. Use the same setup as this machine,https://setiathome.berkeley.edu/show_host_detail.php?hostid=8316299
That machine is using Ubuntu from the 14.04.1 image. It locks the kernel at 3.13 which works with the drivers the card needs, AMD App 1800. I'm using an older driver because it works a little better with my card. You should be fine with the repository driver. Use the image from here, ubuntu-14.04.1-desktop-amd64.iso
I'm kinda fond of the BOINC version 7.8.3 myself, it goes in your Home folder and makes it easier to deal with. If you are going to have to make a clean install, I'd use BOINC 7.8.3, http://www.arkayn.us/forum/index.php?topic=197.msg4519#msg4519
ID: 1902136 · Report as offensive     Reply Quote

Message boards : Number crunching : Ubuntu + AMD HD 8570: Is there a driver/config that works?


 
©2018 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.