SETI@home v7 6.98 for ATI OpenCL released.

Message boards : News : SETI@home v7 6.98 for ATI OpenCL released.
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · Next

AuthorMessage
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 44368 - Posted: 25 Nov 2012, 6:21:56 UTC
Last modified: 25 Nov 2012, 6:23:03 UTC

I get errors on my ATI 6450 when running MB tasks.
Any idea whats wrong, or isn't card supported?
http://setiweb.ssl.berkeley.edu/beta/results.php?hostid=55958&offset=0&show_names=0&state=6&appid=

from the 25'th and forth.
ID: 44368 · Report as offensive
Profile Raistmer
Volunteer tester
Avatar

Send message
Joined: 18 Aug 05
Posts: 2423
Credit: 15,878,738
RAC: 0
Russia
Message 44369 - Posted: 25 Nov 2012, 7:37:28 UTC - in response to Message 44368.  

I get errors on my ATI 6450 when running MB tasks.
Any idea whats wrong, or isn't card supported?
http://setiweb.ssl.berkeley.edu/beta/results.php?hostid=55958&offset=0&show_names=0&state=6&appid=

from the 25'th and forth.


<message>
Maximum elapsed time exceeded
</message>

It's BOINC own issue.
ID: 44369 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 44370 - Posted: 25 Nov 2012, 10:53:54 UTC - in response to Message 44368.  

I get errors on my ATI 6450 when running MB tasks.
Any idea whats wrong, or isn't card supported?
http://setiweb.ssl.berkeley.edu/beta/results.php?hostid=55958&offset=0&show_names=0&state=6&appid=

from the 25'th and forth.

You Basically can't run GPUs that are too disimiliar together, if the slower GPU is more than 10 times slower all it's tasks will end in Maximum Time Exceeded,

OpenCL Platform Name: AMD Accelerated Parallel Processing
Number of devices: 2
Max compute units: 2
Max work group size: 256
Max clock frequency: 625Mhz
Max memory allocation: 199753728
Cache type: None
Cache line size: 0
Cache size: 0
Global memory size: 536870912
Constant buffer size: 65536
Max number of constant args: 8
Local memory type: Scratchpad
Local memory size: 32768
Queue properties:
Out-of-Order: No
Name: Caicos
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1703 (VM)
Version: OpenCL 1.2 AMD-APP (923.1)
Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_atomic_counters_32 cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing
Max compute units: 18
Max work group size: 256
Max clock frequency: 750Mhz
Max memory allocation: 536870912
Cache type: None
Cache line size: 0
Cache size: 0
Global memory size: 1073741824
Constant buffer size: 65536
Max number of constant args: 8
Local memory type: Scratchpad
Local memory size: 32768
Queue properties:
Out-of-Order: No
Name: Cypress
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1703 (VM)
Version: OpenCL 1.2 AMD-APP (923.1)
Extensions: cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_atomic_counters_32 cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing


Claggy
ID: 44370 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 44371 - Posted: 25 Nov 2012, 14:25:11 UTC - in response to Message 44370.  
Last modified: 25 Nov 2012, 14:25:39 UTC

I get errors on my ATI 6450 when running MB tasks.
Any idea whats wrong, or isn't card supported?
http://setiweb.ssl.berkeley.edu/beta/results.php?hostid=55958&offset=0&show_names=0&state=6&appid=

from the 25'th and forth.

You Basically can't run GPUs that are too disimiliar together, if the slower GPU is more than 10 times slower all it's tasks will end in Maximum Time Exceeded,

OpenCL Platform Name: AMD Accelerated Parallel Processing
Number of devices: 2
Max compute units: 2
Max work group size: 256
Max clock frequency: 625Mhz
Max memory allocation: 199753728
Cache type: None
Cache line size: 0
Cache size: 0
Global memory size: 536870912
Constant buffer size: 65536
Max number of constant args: 8
Local memory type: Scratchpad
Local memory size: 32768
Queue properties:
Out-of-Order: No
Name: Caicos
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1703 (VM)
Version: OpenCL 1.2 AMD-APP (923.1)
Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_atomic_counters_32 cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing
Max compute units: 18
Max work group size: 256
Max clock frequency: 750Mhz
Max memory allocation: 536870912
Cache type: None
Cache line size: 0
Cache size: 0
Global memory size: 1073741824
Constant buffer size: 65536
Max number of constant args: 8
Local memory type: Scratchpad
Local memory size: 32768
Queue properties:
Out-of-Order: No
Name: Cypress
Vendor: Advanced Micro Devices, Inc.
Driver version: CAL 1.4.1703 (VM)
Version: OpenCL 1.2 AMD-APP (923.1)
Extensions: cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_3d_image_writes cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_atomic_counters_32 cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing


Claggy


Ok.
Thank you for the answers.
I use exclude gpu 5850 in cc_config.xml to only run on the 6450
And I use it on POEM and that works.
I have reconfigured my cc_config.xml to only run POEM on my 6450 for now.
ID: 44371 · Report as offensive
TRuEQ & TuVaLu
Volunteer tester
Avatar

Send message
Joined: 28 Jan 11
Posts: 619
Credit: 2,580,051
RAC: 0
Sweden
Message 44375 - Posted: 26 Nov 2012, 19:13:09 UTC
Last modified: 26 Nov 2012, 19:14:04 UTC

I found out that buying that 6450 probebly was a mistake.
I bought it with the intention to have it as a second card and use it for Movies.
I found out again that it's still not possible to "clone" desktops between 2 graphic cards. Lucky for me that card was second hand and pretty cheap.

I just wanted to test if it would work with the stock ATI app. It probebly would if it was alone in one computor. I have the intention to set up a small web server some day. There the card is perfect(low power card).

Now I try to run the MB ATI tasks on my 5850.......GAHHHH
I use exclude in the cc_config.xml file to only run on 5850.
It doesn't work to well with the other card in the computor...

I will remove the 6450 soon though. It computes "freeky" with this config on some project combinations and it's not worth the effort to figure out what will work and what will.
ID: 44375 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44422 - Posted: 7 Dec 2012, 15:25:27 UTC
Last modified: 7 Dec 2012, 15:30:05 UTC

with amd releasing the new accelerated streaming sdk 2.8

will we be seeing new compile's of the clients soon?

also when I try to add seti beta to boinc it say's that i have already joined

but does not show as project?

I have done beta work in the past but no longer know how to access it help.
ID: 44422 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 44428 - Posted: 7 Dec 2012, 19:17:09 UTC - in response to Message 44422.  
Last modified: 7 Dec 2012, 19:17:31 UTC

also when I try to add seti beta to boinc it say's that i have already joined

but does not show as project?

I have done beta work in the past but no longer know how to access it help.

Well, reattach your host to Seti Beta using the Seti Beta Website url, your email address and your password then.

Claggy
ID: 44428 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44436 - Posted: 7 Dec 2012, 19:53:44 UTC - in response to Message 44428.  

thought i did that will try again
ID: 44436 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44437 - Posted: 7 Dec 2012, 19:55:45 UTC - in response to Message 44375.  

are you running eyefinity under catalyst control center?
ID: 44437 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44438 - Posted: 7 Dec 2012, 19:58:25 UTC

must have missed something the first time works.
ID: 44438 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44439 - Posted: 7 Dec 2012, 23:13:06 UTC

are these wu the x4 ones?
ID: 44439 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 44440 - Posted: 7 Dec 2012, 23:14:15 UTC - in response to Message 44439.  
Last modified: 7 Dec 2012, 23:15:52 UTC

are these wu the x4 ones?

No, they are standard v7 Wu's.

Claggy
ID: 44440 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44446 - Posted: 8 Dec 2012, 17:48:11 UTC
Last modified: 8 Dec 2012, 17:48:45 UTC

sorry about aborting a bunch astropulse units yesterday then loosing the mb when i reset

project.

as it turns out cuda jobs will only run about 2.68% on an ati card before

crashing the driver.

basically I did not ketch the client before I checked the preference's and they

were set wrong.

evreything is fine now will be more careful from here on.

LOL
ID: 44446 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 44448 - Posted: 8 Dec 2012, 18:43:56 UTC - in response to Message 44446.  
Last modified: 8 Dec 2012, 18:45:37 UTC

as it turns out cuda jobs will only run about 2.68% on an ati card before

crashing the driver.

basically I did not ketch the client before I checked the preference's and they

were set wrong.

evreything is fine now will be more careful from here on.

I was half expecting you to have trouble with the 6.99 ATI app and the Cat 12.11 driver and to have driver restarts,

A bit of background regarding the ATI 6.99 app, when first run the app compiles some kernels and wisdom files using whatever driver is installed, yours were done on this Wu:

Task 11648887

Up until Cat 12.8 this worked right, with Cat 12.10 the compilation caused a faultly kernel file (or enabled a latent app Bug), causing the 6.99 ATI app to find the wrong number of pulses,
My HD7770's compilations were done on Cat 12.8, so i've been producing valid work even when running Cat 12.10, (unlike a lot of Cat 12.10 running hosts around here)
i've recently upgraded to Cat 12.11 Beta 8, now on my offline runs the app produces kernels that produce valid work,
i did remove my Cat 12.8 produced kernel and wisdom files yesterday, and let the ATI app produce new ones, but i got a driver restart soon after it was done,
it corrupted the display enough that i had to reboot, then i had another driver restart soon afterwards, reverted back to the Cat 12.8 produced files and everything is running sweet again,
Raistmer knows about the Cat 12.10 problem, and at some point will look into it,

Claggy
ID: 44448 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44449 - Posted: 8 Dec 2012, 18:59:12 UTC

first astropulse finished ok but afterburner and tthrottle show vary low gpu utilization.

went to look at xml in boinc no xml how do I ajust client?
ID: 44449 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44450 - Posted: 8 Dec 2012, 19:01:51 UTC
Last modified: 8 Dec 2012, 19:06:07 UTC

that is weird ran primgrid to check gpu's went back to setibeta gpu's dropped to 1/4.

the first time gpu #1 was 40% gpu #2 was 10% at least there now balenced.
ID: 44450 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44451 - Posted: 8 Dec 2012, 19:08:43 UTC

at this point only running beta astropulse gpu utilization all over the place but averaging low?
ID: 44451 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 44452 - Posted: 8 Dec 2012, 19:32:48 UTC - in response to Message 44449.  

first astropulse finished ok but afterburner and tthrottle show vary low gpu utilization.

Make sure you free a CPU core, there is a low GPU usage Bug/feature with the ATI/AMD and Nvidia OpenCL apps, if there isn't enough free CPU then GPU utilisation suffers.

Claggy
ID: 44452 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44453 - Posted: 8 Dec 2012, 19:56:45 UTC

first I am running 2 ati hd6870's.

second I am only running gpu tasks just to check that.

so I have two gpu tasks that are bouncing between 10% and 25%

with nothing else running.

after upgrading to boinc 7.31 and downgrading back to 7.28

there is no xml file to adjust.

should i go back farther to 6.81 maybe?
ID: 44453 · Report as offensive
dancer42
Volunteer tester

Send message
Joined: 23 Nov 12
Posts: 15
Credit: 36,669
RAC: 0
United States
Message 44454 - Posted: 8 Dec 2012, 20:33:51 UTC

did a clean install of 12.11 beta11 no differance.

did a clean istall of 12.8

still have problem but graph smother will wait and see.

ID: 44454 · Report as offensive
Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · Next

Message boards : News : SETI@home v7 6.98 for ATI OpenCL released.


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.