Deprecated: Function get_magic_quotes_gpc() is deprecated in /disks/centurion/b/carolyn/b/home/boincadm/projects/beta/html/inc/util.inc on line 663
13 second WUs

13 second WUs

Message boards : SETI@home Enhanced : 13 second WUs
Message board moderation

To post messages, you must log in.

AuthorMessage
Dirk Broer
Volunteer tester

Send message
Joined: 17 Jul 13
Posts: 37
Credit: 2,917,521
RAC: 0
British Virgin Islands
Message 53378 - Posted: 26 Dec 2014, 11:37:39 UTC

I've had several WUs that would run for 13 seconds, pause and start over again in an endless loop of 13 second activity. The Intel OpenCL seems poorly supported too.
ID: 53378 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 53379 - Posted: 26 Dec 2014, 14:30:52 UTC - in response to Message 53378.  

I've had several WUs that would run for 13 seconds, pause and start over again in an endless loop of 13 second activity. The Intel OpenCL seems poorly supported too.

That url is not available for us to view, It is for your use only, with your computers hidden we cannot see what the problem is,

But it's probably this:

WUs with very unusual Autocorr parameters

Claggy
ID: 53379 · Report as offensive
Profile TomTom
Volunteer tester
Avatar

Send message
Joined: 4 Dec 13
Posts: 98
Credit: 10,262,771
RAC: 0
France
Message 53388 - Posted: 27 Dec 2014, 14:50:51 UTC
Last modified: 27 Dec 2014, 15:04:14 UTC

Got the same behavior since 2 weeks on some WUs on all my PC with GPU:
Start computing then "Postponed: Cuda runtime, memory related failure, threadsafe temporary Exit", then waiting for reschedule and restart computing from 0...

Stderr.txt example:

setiathome_CUDA: Found 1 CUDA device(s):
Device 1: Quadro FX 880M, 1024 MiB, regsPerBlock 16384
computeCap 1.2, multiProcs 6
clockRate = 1210 MHz
In cudaAcc_initializeDevice(): Boinc passed DevPref 1
setiathome_CUDA: CUDA Device 1 specified, checking...
Device 1: Quadro FX 880M is okay
SETI@home using CUDA accelerated device Quadro FX 880M
pulsefind: blocks per SM 1 (Pre-Fermi default)
pulsefind: periods per launch 100 (default)
Priority of process set to BELOW_NORMAL (default) successfully
Priority of worker thread set successfully

setiathome enhanced x41zc, Cuda 2.30

Detected setiathome_enhanced_v7 task. Autocorrelations enabled, size 0k elements.
Work Unit Info:
...............
WU true angle range is : 0.545577
re-using dev_GaussFitResults array for dev_AutoCorrIn, 256 bytes
re-using dev_GaussFitResults+32x8 array for dev_AutoCorrOut, 256 bytes
Error on launch (ac_reducePartial<<<grid3, block3, blksize*sizeof(float3)>>>( (float *)dev_AutoCorrIn, dev_ac_partials )), file c:/[Projects]/__Sources/sah_v7_opt/Xbranch/client/cuda/cudaAcc_autocorr.cu, line 200: invalid configuration argument
Exiting
cudaAcc_free() called...
cudaAcc_free() running...
cudaAcc_free() PulseFind freed...
cudaAcc_free() Gaussfit freed...
cudaAcc_free() AutoCorrelation freed...
cudaAcc_free() DONE.
Cuda sync'd & freed.
Preemptively acknowledging a safe temporary exit->
Exit Status: 0
boinc_exit(): requesting safe worker shutdown ->
boinc_exit(): received safe worker shutdown acknowledge ->
Cuda threadsafe ExitProcess() initiated, rval 0
...

Maybe an incorrect argument when calling the functions:
int cudaAcc_FindAutoCorrelation(float *AutoCorrelation, int ac_fftlen, int fft_num )

and the CUDA kernel with the following dimGrid/dimBlock parameters:
int len = ac_fftlen/2;
int blksize = 256;
dim3 block3(blksize,1,1);
dim3 grid3(len/blksize,1,1);
CUDA_ACC_SAFE_LAUNCH( (ac_reducePartial<<<grid3, block3, blksize*sizeof(float3)>>>( (float *)dev_AutoCorrIn, dev_ac_partials )),true);
WU's on first
ID: 53388 · Report as offensive

Message boards : SETI@home Enhanced : 13 second WUs


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.