Astropulse is back!

Message boards : AstroPulse : Astropulse is back!
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · Next

AuthorMessage
rene
Volunteer tester

Send message
Joined: 1 Jan 06
Posts: 16
Credit: 25,648
RAC: 0
Netherlands
Message 14892 - Posted: 18 Feb 2007, 11:18:48 UTC - in response to Message 14868.  

Rene et al

Yes More than one application can exist in a project directory... That is usually defined in the client_state.xml file.

It has been a while since construction of app_info.xml files was discussed

How do the files get there? (Very simplistic subject to small erros in representation)

The best I can recall (simplistic) when you join a project you have no project application. The scheduler sends in the sched_reply_whatever project the basic information about the project (including url's for the appropriate applications and data).

The Core Client displays the information and checks the client_state.xml.

As the client state is read to see if the necessary application files are present on the computer, and replies I do not any files.

The Project then replies you should have "these files" and sends the specific information which is merged into the client_state.xml.

The Core then sends I "need these files," the scheduler then sends the application and support files. They are checked against the information that was stored in the client_state.xml file.

Next the core would send to the scheduler, I have no work to do (according to preferences)... I request 86400 seconds of work. Then work is downloaded.

After that whenever I send information to the project I tell the project what application I am running. If a new application is required, the scheduler would then tell the Core that these are the new files you need and start the process again.

Every time the BOINC Core is started it checks the files (via client_state.xm) in the project directories for integrity!

The Exception: If you have an app_info.xml files it overrides the change of the application. So if there is fact an upgraded application that is supposed to come to you it will not. If the application reported by you is not acceptable No Work will be sent. If there is an error it will delete the files.

So that all said, I would presume the app_info.xml should look something like this (I am a bit rusty in this)

<app_info>
<app>
<name>setiathome_enhanced</name>
</app>
<file_info>
<name>setiathome_5.17_windows_intelx86.exe</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3-1-1a.dll</name>
<sticky/>
</file_info>
<file_info>
<name>seti517.jpg</name>
<sticky/>
</file_info>
<app_version>
<app_name>setiathome_enhanced</app_name>
<version_num>517</version_num>
<file_ref>
<file_name>setiathome_5.17_windows_intelx86.exe</file_name>
<main_program/>
</file_ref>
<app>
<name>astropulse</name>
</app>
<file_info>
<name>ap_4.10_i386-portbld-freebsd</name>
<executable/>
</file_info>
<app_version>
<app_name>astropulse</app_name>
<version_num>410</version_num>
<file_ref>
<file_name>ap_4.10_i386-portbld-freebsd</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>


I just added the <setiathome_enhanced> part to the app_info.xml (without the file_ref and file_info tags), let's see if I get some work tomorrow. Basically I'm trying to run Astropulse-BETA without Seti@Home-BETA ;)

Regards,
Rene
ID: 14892 · Report as offensive
Profile JKeck {pirate}
Volunteer tester
Avatar

Send message
Joined: 15 Jun 05
Posts: 69
Credit: 1,172,804
RAC: 0
United States
Message 14895 - Posted: 18 Feb 2007, 13:56:19 UTC - in response to Message 14892.  

I just added the <setiathome_enhanced> part to the app_info.xml (without the file_ref and file_info tags), let's see if I get some work tomorrow. Basically I'm trying to run Astropulse-BETA without Seti@Home-BETA ;)

Regards,
Rene

Although I am not really familiar with the workings of the app_info.xml file I expect that will still download work but return it with an unrecoverable error. I would try setting the version to something pretty low like 1.11 to achieve what you desire. That way hopefully the server will refuse to send you work since it thinks your application is outdated.
BOINC WIKI

BOINCing since 2002/12/8
ID: 14895 · Report as offensive
Josef W. Segur
Volunteer tester

Send message
Joined: 14 Oct 05
Posts: 1137
Credit: 1,848,733
RAC: 0
United States
Message 14901 - Posted: 18 Feb 2007, 18:51:37 UTC - in response to Message 14895.  

I just added the <setiathome_enhanced> part to the app_info.xml (without the file_ref and file_info tags), let's see if I get some work tomorrow. Basically I'm trying to run Astropulse-BETA without Seti@Home-BETA ;)

Regards,
Rene

Although I am not really familiar with the workings of the app_info.xml file I expect that will still download work but return it with an unrecoverable error. I would try setting the version to something pretty low like 1.11 to achieve what you desire. That way hopefully the server will refuse to send you work since it thinks your application is outdated.

I agree with that suggestion, but actually I think the original version rene posted was correct. The real hindrance is probably that there simply isn't any AstroPulse work available. It looks like there were only 170 WUs created, the 23 created January 30:
wuid=309688 through wuid=309711
and 147 more on February 8:
wuid=340432 through wuid=340578
I've only spot checked, but none seem to be in a condition where they'll send any more copies out, and they seem to have reached that state by about February 12.
                                                                Joe
ID: 14901 · Report as offensive
Dotsch
Volunteer tester
Avatar

Send message
Joined: 14 Jun 05
Posts: 103
Credit: 93,106
RAC: 0
Germany
Message 14939 - Posted: 19 Feb 2007, 7:58:40 UTC

Rene, I have simliar problems with the app_info.xml.
But, I have written Eric a mail. He said, that he must do some modifications at the code. So I think, we should wait a little bit with the portings, till Eric has done the changes.
ID: 14939 · Report as offensive
rene
Volunteer tester

Send message
Joined: 1 Jan 06
Posts: 16
Credit: 25,648
RAC: 0
Netherlands
Message 14958 - Posted: 19 Feb 2007, 20:42:07 UTC - in response to Message 14901.  

I just added the <setiathome_enhanced> part to the app_info.xml (without the file_ref and file_info tags), let's see if I get some work tomorrow. Basically I'm trying to run Astropulse-BETA without Seti@Home-BETA ;)

Regards,
Rene

Although I am not really familiar with the workings of the app_info.xml file I expect that will still download work but return it with an unrecoverable error. I would try setting the version to something pretty low like 1.11 to achieve what you desire. That way hopefully the server will refuse to send you work since it thinks your application is outdated.

I agree with that suggestion, but actually I think the original version rene posted was correct. The real hindrance is probably that there simply isn't any AstroPulse work available. It looks like there were only 170 WUs created, the 23 created January 30:
wuid=309688 through wuid=309711
and 147 more on February 8:
wuid=340432 through wuid=340578
I've only spot checked, but none seem to be in a condition where they'll send any more copies out, and they seem to have reached that state by about February 12.
                                                                Joe


This seems to be the case indeed. With a fake setiathome_enhanced entry (without an application), BOINC managed to download a seti 5.17 workunit which it didn't know how to process. I reverted the app_info to the originally posted version.
ID: 14958 · Report as offensive
rene
Volunteer tester

Send message
Joined: 1 Jan 06
Posts: 16
Credit: 25,648
RAC: 0
Netherlands
Message 15928 - Posted: 11 Mar 2007, 10:41:46 UTC - in response to Message 14901.  

I just added the <setiathome_enhanced> part to the app_info.xml (without the file_ref and file_info tags), let's see if I get some work tomorrow. Basically I'm trying to run Astropulse-BETA without Seti@Home-BETA ;)

Regards,
Rene

Although I am not really familiar with the workings of the app_info.xml file I expect that will still download work but return it with an unrecoverable error. I would try setting the version to something pretty low like 1.11 to achieve what you desire. That way hopefully the server will refuse to send you work since it thinks your application is outdated.

I agree with that suggestion, but actually I think the original version rene posted was correct. The real hindrance is probably that there simply isn't any AstroPulse work available. It looks like there were only 170 WUs created, the 23 created January 30:
wuid=309688 through wuid=309711
and 147 more on February 8:
wuid=340432 through wuid=340578
I've only spot checked, but none seem to be in a condition where they'll send any more copies out, and they seem to have reached that state by about February 12.
                                                                Joe


I got some work last night, but the results don't look too promising: 1609498 (no output file?) , and 1609419, 1609381, 1909380 (result file too large)

The modified source code (infrastructure/auto*) I use for FreeBSD is available at http://home.tiscali.nl/rladan/distfiles/boinc-astropulse-4.10.tar.gz , the patchset at http://home.tiscali.nl/rladan/freebsd/ap-port.tgz

ID: 15928 · Report as offensive
Dotsch
Volunteer tester
Avatar

Send message
Joined: 14 Jun 05
Posts: 103
Credit: 93,106
RAC: 0
Germany
Message 16232 - Posted: 14 Mar 2007, 19:03:36 UTC - in response to Message 15928.  

I have the same problem. As I have written, Eric said that he would do some changes in the source...
ID: 16232 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 17266 - Posted: 28 Mar 2007, 20:29:38 UTC

Windows Astropulse is out, just started my first unit of it.

Claggy.

ID: 17266 · Report as offensive
Profile Pappa
Volunteer tester
Avatar

Send message
Joined: 13 Nov 05
Posts: 1724
Credit: 3,121,901
RAC: 0
United States
Message 17282 - Posted: 28 Mar 2007, 22:48:19 UTC
Last modified: 28 Mar 2007, 22:49:10 UTC

We have a Seperate Astropluse Message Board

Please report Errors There


Regards

Pappa



Thanks to Paul and Friends
Please consider a Donation to the Seti Project
ID: 17282 · Report as offensive
Misfit
Volunteer tester
Avatar

Send message
Joined: 15 Jun 05
Posts: 3400
Credit: 1,026,406
RAC: 0
United States
Message 17283 - Posted: 28 Mar 2007, 22:53:01 UTC - in response to Message 17282.  
Last modified: 28 Mar 2007, 22:55:13 UTC

We have a Seperate Astropluse Message Board

Please report Errors There

And DO NOT use the SETI optimized app if you want to crunch Astropulse.
The associated app_info.xml file will not allow you to download the new application.
If this is the case you will need to RESET then Update the project to pick up the Astropulse app.
me@rescam.org
ID: 17283 · Report as offensive
Claggy
Volunteer tester

Send message
Joined: 29 May 06
Posts: 1037
Credit: 8,440,339
RAC: 0
United Kingdom
Message 17286 - Posted: 28 Mar 2007, 22:56:46 UTC

Sorry, i forgot, & i have, already!, but probably in the wrong thread again.

Claggy.
ID: 17286 · Report as offensive
P . P . L .
Volunteer tester

Send message
Joined: 28 Jan 06
Posts: 185
Credit: 22,285
RAC: 0
Australia
Message 17302 - Posted: 28 Mar 2007, 23:53:07 UTC

A question.

For those of us using Joe's app what do we do, add something to the

app info file?


ID: 17302 · Report as offensive
Profile Pappa
Volunteer tester
Avatar

Send message
Joined: 13 Nov 05
Posts: 1724
Credit: 3,121,901
RAC: 0
United States
Message 17305 - Posted: 29 Mar 2007, 0:07:54 UTC - in response to Message 17302.  
Last modified: 29 Mar 2007, 0:57:56 UTC

Peter

I would suspect that you would need to download the Astropulse Files seperately
* ap412.jpg
* astropulse_4.12_windows_intelx86.exe
* astropulse-4.12_AUTHORS
* astropulse-4.12_COPYING

Then ammend the app_info.xml... Where is Joe when we need him...

I will see what I can do however I am not running Joe's App at the moment...

Edit:

* I did a quick grab of the necessary files and ammended Joe's app_info.xml
You can grab a copy of the Astropulse files and the TEST "app_info.xml Here...

Joe Please look to insure I did not mess it up... I am a bit rusty with the app_info.xml

* As I forced an Astropulse Workunit to start I have some information.
- The Astropulse App is about 8 Meg
- The Astropulse Workunit is about 8 Meg
- Taskmanager reports the Memory required to run Astropulse is 144 megabytes.


A question.

For those of us using Joe's app what do we do, add something to the

app info file?



Thanks to Paul and Friends
Please consider a Donation to the Seti Project
ID: 17305 · Report as offensive
Josef W. Segur
Volunteer tester

Send message
Joined: 14 Oct 05
Posts: 1137
Credit: 1,848,733
RAC: 0
United States
Message 17332 - Posted: 29 Mar 2007, 4:19:01 UTC - in response to Message 17305.  

* I did a quick grab of the necessary files and ammended Joe's app_info.xml
You can grab a copy of the Astropulse files and the TEST "app_info.xml Here...

Joe Please look to insure I did not mess it up... I am a bit rusty with the app_info.xml

* As I forced an Astropulse Workunit to start I have some information.
- The Astropulse App is about 8 Meg
- The Astropulse Workunit is about 8 Meg

The app_info.xml looks good except the set517.jpg in the astropulse part should be changed to ap412.jpg. And for those running 5.17SB1 obviously the SETI Beta part should reflect that app.

Being on dial-up, I'm giving AstroPulse a pass for now.
                                                                Joe
ID: 17332 · Report as offensive
Profile Byron Leigh Hatch @ team Carl ...
Volunteer tester
Avatar

Send message
Joined: 15 Jun 05
Posts: 970
Credit: 1,495,169
RAC: 0
Canada
Message 17380 - Posted: 29 Mar 2007, 14:53:24 UTC - in response to Message 17332.  
Last modified: 29 Mar 2007, 14:55:34 UTC



* I did a quick grab of the necessary files and ammended Joe's app_info.xml
You can grab a copy of the Astropulse files and the TEST "app_info.xml Here...

Joe Please look to insure I did not mess it up... I am a bit rusty with the app_info.xml

* As I forced an Astropulse Workunit to start I have some information.
- The Astropulse App is about 8 Meg
- The Astropulse Workunit is about 8 Meg

The app_info.xml looks good except the set517.jpg in the astropulse part should be changed to ap412.jpg. And for those running 5.17SB1 obviously the SETI Beta part should reflect that app.

Being on dial-up, I'm giving AstroPulse a pass for now.
                                                                Joe


Hi Joe

Hi Pappa

Hi everyone

Oops .... sorry .. can anyone tell me what I'm doig wrong ?


I'm crunching astropules ..... but it does not show up _here_ ?






ID: 17380 · Report as offensive
Profile keyboards
Volunteer tester
Avatar

Send message
Joined: 11 Feb 06
Posts: 309
Credit: 4,022,545
RAC: 0
United States
Message 17381 - Posted: 29 Mar 2007, 15:15:34 UTC - in response to Message 17380.  

Byron -

The problem is that the AstroPulse WUs are an "earlier" RESULT ID than your BETA WUs. All your results are sorted by RESULT ID with no option to sort on ,oh let's say DATE SENT. They are there, but may be pages deep in the listings of results (depending on the proficiency of your machine(s)).

BTW - Probably should start posting in the AstroPulse Forum (where I happened to ask the same thing last evening ;-))


Hi Joe

Hi Pappa

Hi everyone

Oops .... sorry .. can anyone tell me what I'm doig wrong ?

I'm crunching astropules ..... but it does not show up _here_ ?



!!Stupidity should be PAINFUL!!
ID: 17381 · Report as offensive
Profile Byron Leigh Hatch @ team Carl ...
Volunteer tester
Avatar

Send message
Joined: 15 Jun 05
Posts: 970
Credit: 1,495,169
RAC: 0
Canada
Message 17382 - Posted: 29 Mar 2007, 15:22:48 UTC - in response to Message 17381.  

Byron -

The problem is that the AstroPulse WUs are an "earlier" RESULT ID than your BETA WUs. All your results are sorted by RESULT ID with no option to sort on ,oh let's say DATE SENT. They are there, but may be pages deep in the listings of results (depending on the proficiency of your machine(s)).

BTW - Probably should start posting in the AstroPulse Forum (where I happened to ask the same thing last evening ;-))


Hi Joe

Hi Pappa

Hi everyone

Oops .... sorry .. can anyone tell me what I'm doig wrong ?

I'm crunching astropules ..... but it does not show up _here_ ?




Hi Keyboars thank a million !

Best Wishes
Byron
:-)


ID: 17382 · Report as offensive
Profile Pappa
Volunteer tester
Avatar

Send message
Joined: 13 Nov 05
Posts: 1724
Credit: 3,121,901
RAC: 0
United States
Message 17383 - Posted: 29 Mar 2007, 15:30:06 UTC - in response to Message 17332.  

Joe I fixed the app_info.xml in the Zip file so it now correct...

* I did a quick grab of the necessary files and ammended Joe's app_info.xml
You can grab a copy of the Astropulse files and the TEST "app_info.xml Here...

Joe Please look to insure I did not mess it up... I am a bit rusty with the app_info.xml

* As I forced an Astropulse Workunit to start I have some information.
- The Astropulse App is about 8 Meg
- The Astropulse Workunit is about 8 Meg

The app_info.xml looks good except the set517.jpg in the astropulse part should be changed to ap412.jpg. And for those running 5.17SB1 obviously the SETI Beta part should reflect that app.

Being on dial-up, I'm giving AstroPulse a pass for now.
                                                                Joe


Thanks to Paul and Friends
Please consider a Donation to the Seti Project
ID: 17383 · Report as offensive
Misfit
Volunteer tester
Avatar

Send message
Joined: 15 Jun 05
Posts: 3400
Credit: 1,026,406
RAC: 0
United States
Message 17659 - Posted: 31 Mar 2007, 2:11:42 UTC

For those of you who wish to run AP and only AP - NO Enhanced - this is your app_info.xml:

<app_info>
<app>
<name>astropulse</name>
</app>
<file_info>
<name>astropulse_4.12_windows_intelx86.exe</name>
<executable/>
</file_info>
<file_info>
<name>libfftw3f-3-1-1a.dll</name>
<sticky/>
</file_info>
<file_info>
<name>ap412.jpg</name>
<sticky/>
</file_info>
<app_version>
<app_name>astropulse</app_name>
<version_num>412</version_num>
<file_ref>
<file_name>astropulse_4.12_windows_intelx86.exe</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

As anyone can see I have a ton of AP units but no Enhanced units.
me@rescam.org
ID: 17659 · Report as offensive
Profile kb7rzf
Volunteer tester
Avatar

Send message
Joined: 21 Aug 05
Posts: 720
Credit: 43,124
RAC: 0
United States
Message 17923 - Posted: 1 Apr 2007, 22:27:51 UTC

I got a question, hopefully someone can answer,

Why are people aborting Seti Enhanced WU's just to get AstroPulse WU's? We still need to test both apps, am I right? See Here I'm just curious, thats all.

Jeremy
ID: 17923 · Report as offensive
Previous · 1 · 2 · 3 · 4 · 5 · Next

Message boards : AstroPulse : Astropulse is back!


 
©2022 University of California
 
SETI@home and Astropulse are funded by grants from the National Science Foundation, NASA, and donations from SETI@home volunteers. AstroPulse is funded in part by the NSF through grant AST-0307956.